Add test for HDF5 version. Add new requirement.

Description

Enforce the HDF5 version >= 1.8 is used in building HDF5.

(1) Add for both autotools and cmake.
(2) Remove old 1.6 code in ADFH.c

Assignee

Scot Breitenfeld

Reporter

Scot Breitenfeld

Fix versions

Priority

Blocker

Components

Configure